如何安装composer 工具

composer 是 PHP 的一个依赖管理工具,用来辅助安装一些PHP依赖的库文件。现在不少PHP框架都是可以用composer来安装依赖(例如 yii,laraver,thinkphp等)
安装composer前请确定你的电脑已经安装了PHP(需要 PHP 5.3.2+ 以上版本;win+r 打开运行窗口->打开cmd命令->输入 php -v就可以查看当前php版本)且需要开启 openssl(开放源代码的软件库包,应用程序可以使用这个包来进行安全通信,避免窃听,同时确认另一端连接者的身份。),如果没有安装的话推荐安装phpstudy(是个非常好用的php调试环境的程序集成包)
这里写一下windows和linux的安装教程(贫穷的我买不起苹果,所以请忽略为啥没有Mac OS 系统安装案例)

windows 环境下

首先找到php.ini(phpstudy环境下可以其它选项菜单->配置文件->php-ini打开)把 extension=php_openssl.dll前边的分号(;)去掉,打开openssl配置
然后前往composer官网下载exe安装包,打开安装包一路下一步,狂点不回头啊(๑乛◡乛๑ 当然你可以自己选择一下路径 ,还有php版本)。
安装完成后查看是否安装成功 win+r 打开运行窗口->打开cmd命令->输入 composer -v ,出现一下图案表示安装成功。
如何安装conposer 工具
最后我们可以更改 Packagist 为国内镜像(避免安装一些国外的依赖文件被墙安装不下来或者慢情况,我安装laraver时就发现vendor没有安装成功_(:3」∠❀)):
composer config -g repo.packagist composer https://packagist.phpcomposer.com

linux环境下

shell 执行以下命令
php -r "copy('https://install.phpcomposer.com/installer', 'composer-setup.php');"
php composer-setup.php

如何安装conposer 工具
移动 composer.phar,这样 composer 就可以进行全局调用:
mv composer.phar /usr/local/bin/composer
切换国内镜像的命令同win一样。当lnmp安装或者切换镜像出现 Warning: putenv() has been disabled for security reasons in…的问题是LNMP 禁用了部分存在危险的PHP函数。
如何安装conposer 工具
解决办法:打开php.ini找到disable_functions将后面的putenv删除
查看命令 composer -v

更新composer命令
composer selfupdate

赞(1) 打赏
转载请注明出处:猿客栈 » 如何安装composer 工具
分享到:

评论 1

  1. #1

    <script>
    alert(‘测试注入’);
    window.location.href="http://think.yuankezhan.com&quot;;
    </script>

    张海春11个月前 (11-01)回复

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏